Error while scanning

Viewed 5473 times, With a total of 22 Posts
Wechseln zu: Navigation, Suche

Jump to page 12Next 16Last
Gets Around
Wiki Edit 19
Threads 8
Posts 56
Error during setup for Scan
Simon,
As I go through the steps, beginning to scan, after picking the "process" button, the following message comes up and everything stops:
Message:
A generic error occurred in GDI+.

Stacktrace
  at System.Drawing.Image.Save(String filename, ImageCodecInfo encoder, EncoderParameters encoderParams)
at System.Drawing.Image.Save(String filename, ImageFormat format)
at ScanController.MainFrame.System.Windows.Forms.IMessageFilter.PreFilterMessage(Message& m)
at System.Windows.Forms.Application.ThreadContext.ProcessFilters(MSG& msg, Boolean& modified)
at System.Windows.Forms.Application.ThreadContext.PreTranslateMessage(MSG& msg)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FPreTranslateMessage(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at ScanController.MainFrame.Main(String[] args)

I haven't changed anything in software or hardware.
Johnc

Gets Around
Wiki Edit 202
Threads 5
Posts 61
Hi sorry for the late reply -

did this error went away in the meantime maybe after a restart?
If it still pops up please report back

Gets Around
Wiki Edit 19
Threads 8
Posts 56
error message
Yes it still is popping up. See my personal email to you of Aug 7th.
I went to personal email because you evidently check your regular email more frequently then the forum.
Johnc

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Simon,
As a side note - When running a scan as described in my email, on the last window before processing, the output folder for storing the strips is shown. I am using a different HD for the project file, but the folder shown on the window is not complete. Each time I have to browse to it, otherwise it won't scan. How do I correct this so it comes up automatically.
Johnc

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Simon,
In my attempts to troubleshoot the problem, I started the software setup from the beginning, with a different 4 letter project name "Sca2". Cintovid pro accepted it and began scanning. After scanning to strips, it stopped with the same error message as above.
Confused!
Anybody with suggestions please jump in!
Johnc
Edited On 14:30:31 PM - Tue, Aug 11th 2015 by John

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Simon,
Do you have any suggestions as to what is causing the error message?
As I mentioned in an earlier email, if I start from scratch, going through the steps to scan strips, the program will work normally for a number of scans then stop with the error message. I was able to scan 197 strips on one attempt, but nothing since then.
any suggestions?

I am running cinetovid pro, latest version from Wolfgang on a PC, running WinXP. I am assuming that since the procedure I am following allowed scan of 197 strips, then the problem is not me!!
help please!
Johnc

Gets Around
Wiki Edit 997
Threads 10
Posts 73
Error during scanning with Beta Version
Hello John,

the INI File slightly has changed to reflect the new features of the 2.0 BetaVersion.

I recommend to delete the old INI file and generate a new one.

If this does not help, please contact me again.

I will upload a new Beta Version - use the old download link
http://wkurz.com/upload/CineToVidPro.zip

(still needs to recreate the INI file )

Wolfgang


Epson Perfection V750 Photo, Windows 7 (64 Bit) 16 GB. ScanController V0.7 mit Arduino Duemilanove, CineToVidPro 1.4

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Wolfgang,
Thanks!
Be advised that the error message was appearing before you posted the Beta version.
I will download the revised Beta and try it out.
Question ; What is the correct procedure for appending strips to an existing file?
What happened to Simon?
Johnc

Gets Around
Wiki Edit 19
Threads 8
Posts 56
simon
wolfgang,
All fixes todate still don't work.
I have tried the Beta version, started from scratch with a new project and the same error message comes up each time.
checking the postings, Simon has not been on line, with the forum in months. Has he moved on?
Will you be answering queries from now on?
concerned,
Johnc

Gets Around
Wiki Edit 997
Threads 10
Posts 73
CineToVidPro Beta removed
Hello John,

I have been on holidays in late September and early October.

Now being back, I have released Version 2.0 of CineToVidPro and removed the 1.99 Beta Versions.
Please go to the standard "download" site and install the new CineToVidPro version.
(This does not affect potential problems with the ScanController - the ScanController is an independent program maintained by Simon).

Wolfgang
Edited On 8:23:41 AM - Tue, Oct 20th 2015 by Hannibalstgt

Gets Around
Wiki Edit 202
Threads 5
Posts 61
hi John,


was swamped with work - i suspect the path where the image is to be saved does not exist or is not writable.
Does this error only occur when executing Scancontroller out of the CineToVidPro Software?
Please try to run ScanController on its own. If the error doesn't show up there a wrong Output dir is supplied by CineToVid, if the error happens when ScanController is invoked directly , hmm we'll have to look into that again
greets
Simon

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Simon,
To add to my previous posts, I just setup to run a scan series.
Everything seems to be appropriate, except that I cannot find any place to insert the number of frames to scan, and the number of the first frame. when i go to the extraction settings window, on the right side it says extraction ?, but the two entries are missing. I went to the ini file for the project, and the entries are missing, so I manually entered the info in the ini file. I want to scan 5 frames, and the starting frame is 0. So in entered 5 and zero.
I started the run cycle and it is scanning as it should.
Am I missing something with the scan controller.
I am concerned that I am not going through the correct sequence in setting up the process.
I start by opening cintovid pro 2.0; create a new project, and filling in all the blanks.
Question; should i open scan controller in advance of launching cinetovid pro?
Johnc

Gets Around
Wiki Edit 997
Threads 10
Posts 73
ScanController and CineToVidPro are two independnet programs.
Hello John,
I asume you have downloaded Version 2.0 (20151026) of CineToVidPro. If not, do it now.

If you want to scan strips you can invoke the ScanController from CineToVidPro (as it allways was),
but you first have to set the path to this program under "Functions -> define required commands".

The ScanController just runs in a separate task using the invocation parameters from CineToVidPro, but completely independent from CineToVidPro.
But the better alternative is to invoke the ScanController independently just by calling the
ScanController.exe . This uses the amount of available working storage better because CineToVidPro is not active then and therefore does not need working storage.

In the ScanController you than have to set (because there are no invocation parameters) the target folder for the scanned strips and you can specify the first strip number and how many strips you want to scan.

The width and height of the strips to be scanned is set in the Scanners Twain program (for Epson scanner in EpsonScan ! Differently named for other scanners!).

You cannot and need not to set the first frame number and how many frames to scan per strip.

This is set in CineToVidPro after the strips have been scanned and you want to extract the frames
from the scanned strips.
This is done in the main window below "Scanner Settings".

You can find a detailed description in the CineToVidPro Help file.

Wolfgang

Gets Around
Wiki Edit 19
Threads 8
Posts 56
Thannks wolfgang!
going through the documents on the wiki several times, and then attempting the scanning process 3-4 times pointed out the error in my methods. The path to the strips folder was not complete, and cintovidpro was not putting the scanned strips in the proper folder.
In the last step before scanning begins, selecting "run" brings up a window with the base directory displayed.  The dir name comes up as "film" which is only part of the folder name. I had to expand that to film Project/SCA3/strips/0. on my last attempt, I got 22 strips scanned and moved on to generate frames which worked.  At that point, things came to a halt, as I had not properly loaded "FFmpeg".  So far, all attempts to get FFmpeg loaded have not worked.  I googled "FFmpeg" and got a lot of confusing material with all sorts of choices.  
Question: What should I download? Is there a *.exe file which goes in the documents blank on the main screen? Which version (2.8.1?) When I install the program, there is no shortcut, no readme, no nothing. does the program reside in the background?
Question: Previously, I found some instructions on progressing thru the processing stages, but have misplaced the sheets. I do find a similar document, but it must be for older issues of cintovidpro, as the windows don't match what I see in ver.2.0.
Question: The film I am scanning is very dark, so I had to check the box on the Epson scan setup that deals with backlight. This improved things greatly, but the images seem to bloom in the white spots like they are too bright. Any fix for dealing with the dark images?
Last question: If there are some Bad frames in the scanned group, can replacement frames be inserted with the same frame numbers, or do I just delete the bad frames, leaving a gap in the numbering? Is there some trick to renumbering the frames?
Lots of questions! Please bear with me, I am getting close.

Gets Around
Wiki Edit 997
Threads 10
Posts 73
Hello John,

I do not quite understand your question. What do you mean by "documents blank on the main screen"

And you get a detailed explanation what to do in the Help Files of the two programs.
The help files are referring to the most recent versions of the programs - at least for CineToVidPro. For the ScanController there have been no serious changes between the most recent versions.

You should install the lates version of ScanContoller (0.8) from the Wiki page - see at the left border: Themen -> ScanController -> Download latest version.
Be sure, that you select the proper script according to your hardware (For Arduino - download the sketch to the Arduino board) used to control the stepper motor. Simon introduced a change in the scripts (sketches) between version 0.7 and 0.8 (that is: the scripts for 0.8 ScanController are different from the scripts for Version 0.7x. For 0.8 use sketch stepper 04 if you use Arduino with Pollin)

In the ScanController main window menu bar if you select "Help -> Help" the detailed Help file opens. When selecting "File - > run" you can select the target folder (via button with the 3 dots) for the strips as well as the other control fields. I think it is self explaining.

If you have not yet created the project folders so far, you can do that using CineToVidPro by creating a new project. Or just create them using the Windows File Explorer window. But keep in mind, that CineToVidPro expects a certain folder structure.

To use CineToVidPro you should download the most recent version V 2.0 (20151026).
You will find it on my homepage http://wkurz.com under Downloads (Button on the left side of the window) or in the Wikis Main Page under the announcement of Version 2.0 - you can use the German or the English text, The result of the download is identical.

Then install CineToVidPro 2.0 just by expanding the downloaded CineToVidPro,zip file into your installaion folder. You can use C:\programs\CineToVidPro.
If you invoke it (CineToVidPro.exe in your installation folder), you find the help files by pressing "Help -> Help" in the menu bar of the main window.
I recommend to go through this document. It contains everything to run CineToVidPro properly - explanations - I think - are pretty detailed.

If you have dark movies I recommend to use the automatic scanning setting, that is the black bowl with the two red arrows in the EpsonScan left window. If that delivers insufficient results use the third button in this row and adjust the image brightnes by manipulating the curves.

On the other hand (which is probably the better solution), you can also adjust the movie colors in the final processing step in the movie editor ( e.g.Magix) after you have edited your movie. This is still early enough. You will get the adjusted colors during rendering (mixdown) of your movie. This has the advantage, that you can do the adjustment individually for each scene.

Regards
Wolfgang

Gets Around
Wiki Edit 19
Threads 8
Posts 56
wolfgang,
Thanks for the help (your email of 16:35 pm)
See my last email.
Just loaded ffmpeg successfully and am appending more strips to those already completed, then I will try to make a movie.
Johnc


Forum >> Software >> CineToVId and ScanController
Jump to page 12Next 16Last



Who's here now Members 0 Guests 0 Bots/Crawler 0


AWC's: 2.5.12 MediaWiki - Stand Alone Forum Extension
Forum theme style by: AWC